当前位置:首页>Linux>Linux中Nginx安装

Linux中Nginx安装

  • 2026-10-11 07:48:48
Linux中Nginx安装

1.安装依赖

//一键安装yum -y install gcc zlib zlib-devel pcre-devel openssl openssl-devel

2.下载解压安装包

//创建文件夹cd /usr/localmkdir nginxcd nginx//下载tar包wget http://nginx.org/download/nginx-1.13.7.tar.gztar -xvf nginx-1.13.7.tar.gz

3.安装

执行make命令时可能会报错:nginx编译-zierror: ‘struct crypt_data‘ has no member named ‘current_salt‘,查看Nginx安装时执行make命令报错如何解决

//进入nginx目录cd /usr/local/nginx//进入目录cd nginx-1.13.7//执行命令 考虑到后续安装ssl证书 添加两个模块./configure --with-http_stub_status_module --with-http_ssl_module//执行make命令make//执行make install命令make install

4.启动nginx

/usr/local/nginx/sbin/nginx -c /usr/local/nginx/conf/nginx.conf

5.配置nginx.conf文件

# 打开配置文件vi /usr/local/nginx/conf/nginx.conf

将端口号改成8089(随便设置),因为可能apeache占用80端口,apeache端口尽量不要修改,我们选择修改nginx端口。

将localhost修改为你服务器的公网ip地址。

6.重启nginx

/usr/local/nginx/sbin/nginx -s reload

查看nginx进程是否启动:

ps -ef | grep nginx

7.若想使用外部主机访问nginx

需要关闭服务器防火墙或开放nginx服务端口,端口为上一步nginx.conf的配置端口:

centOS6及以前版本使用命令:

systemctl stop iptables.service

centOS7关闭防火墙命令:

systemctl stop firewalld.service

注意:如果云服务器设置了厂商的防火墙,和此处的系统级防火墙不是一个,云厂商的防火墙页面设置的是虚拟的防火墙,如果虚拟防火墙设置了,系统级防火墙也打开了但是没设置端口规则,那么也访问不通实例。

关闭防火墙会导致服务器有一定风险,所以建议是单独开放服务端口 :

开放80端口:

firewall-cmd --zone=public --add-port=80/tcp --permanent

查询端口号80 是否开启:

firewall-cmd --query-port=80/tcp

重启防火墙:

firewall-cmd --reload

随后访问该ip:端口 即可看到nginx界面。

8.访问服务器ip查看(备注,由于我监听的仍是80端口,所以ip后面的端口号被省略)

我的域名已经解析到服务器的公网ip了,所以直接访问

常用命令:

进入安装目录中,

命令:

cd /usr/local/nginx/sbin

启动,关闭,重启,命令:

启动

./nginx

关闭

./nginx -s stop

重启

./nginx -s reload

最新文章

随机文章