当前位置:首页>Linux>Mysql安装-Linux-Ubuntu

Mysql安装-Linux-Ubuntu

  • 2026-10-11 06:58:55
Mysql安装-Linux-Ubuntu
今日主图2023-03-19 雁北茶的AI作品 AI引擎:百度飞浆

最近想了解一下flask框架,以前用Djang写过项目,但时间太久忘差不多了,心血来潮看看这个传说中的轻型框架怎么样,笔记本硬盘比较紧张就不开虚拟机了,直接上阿里云开个linux的云电脑,今天刚好要安装一个mysql,记录一下安装过程;

电脑:无影云桌面
镜像:Linux-Ubuntu-2004

1.打开终端:

ctrl+Alt+T

2.直接运行sudo apt  install mysql-server 安装MYSQL,简单粗暴

sudo apt  install mysql-server

后续弹出是否继续输入Y点击回车

3.查看MySQL状态 : sudo  service  mysql  status

看到Active:active(running)即运行

  • 启动/停止/重启服务:sudo  service  mysql    start/stop/restart
  • 配置文件:/etc/mysql
  • 数据库存储目录 :/var/lib/mysql

4.连接数据库

 mysql    -h  主机地址   -u  用户名    -p

本地登录可忽视(省略)-h 主机地址

mysql -u root -p
# 默认安装下root无密码,直接回车登录

如果出现报错 报错:ERROR 1698 (28000): Access denied for user 'root'@'localhost'
原因:安装新版本mysql,root密码是随机的,也不是空密码,所以要通过查看随机密码进入,再进行修改原来的密码。

继续往下,如果已经成功登录,后续可省略;

5.查看安装自动生成的随机用户及密码:

sudo cat /etc/mysql/debian.cnf

6.用该用户名及密码登录

mysql    -u  debian-sys-maint    -p 
#密码: ZUqeXHrDgwzNeoGn
#mysql在输入密码时不可见的,输入完正常回车就行

6.查看user表

use mysql;
select user,plugin from user;

7.修改root密码格式

目前插件格式

  • mysql_native_password(老)
  • caching_sha2_password(最新)
    从安全性来讲建议使用最新插件,但新插件可能会造成某些特殊情况下与其他老版本软件(插件,包)不兼容
update user set plugin='caching_sha2_password' where user='root'; # 修改其密码插件
select user,plugin from user; # 查询其用户

8.刷新权限

flush privileges;# 确保后续操作

9.设置root密码

alter user 'root'@'localhost' identified by '你的密码';

10.刷新权限

flush privileges;# 确保后续操作

11.退出

exit

12.重启mysql服务

service mysql restart

13.再次使用root登录

mysql -u root -p
# 用刚刚设置的密码

最新文章

随机文章